Apple果往往举出这样的例子:
NSErr或__strong *err或= nil;
或
-(BOOL)performOperationWithError:(NSErr或* __autoreleasing *)error;
I d find it much more readable and logical if I could do it this way:
__strong NSErr或*err或= nil;
-(BOOL)performOperationWithError:(__autoreleasing NSError**)error;
A quick test revealed that the compiler is not complaining about my way of writing it. Am I doing it wrong anyways, 或is it just fine to write it like this?