Is it recommended to count in small loops (where possible) down from length - 1 to zero instead of counting up to length - 1?
1) 下降
for (int i = a.length - 1; i >= 0; i--) {
if (a[i] == key) return i;
}
b) ing
for (int i = 0; i < a.length; i++) {
if (a[i] == key) return i;
}
第一个是稍快的,第二个是(因为与零相比较快),但在我看来,差不多有错误。 此外,可能无法通过今后改进联合核查机制来优化第一个机制。 任何这方面的想法?